Ford Ecosport Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi all
A mechanic has told me this is common with eco sports
2015 1.5d
The air conditioning has suddenly stopped working.
Gas level is green
Fuses are good
Relay is good
Ac button lights up when on
No dip in engine revs and can’t hear the ac clutch engaging, leading to no cold air.
He says common problem is the pump... it’s not done a lot of work, so is this your experience?
Tia
Al
 

·
Registered
Joined
·
55 Posts
I put my air conditioning on the other day, temp on Lo in the blue, pressed air con button, turned blower up, not was hardly that cold? I have a 2015 eco 1.5 TDCI.
 

·
Registered
Joined
·
55 Posts
Am I doing anything wrong regarding air con. Tried it other day, didn't seem cold. I have 2015 ecosport, 1.5 TDCI. I turned temp dial so it read low. Put on the a/c button, turned blower up a bit, but didn't seem hardly cold. Not 4 year old yet. Will have another look, and listen to see if the engine changes, as my old c max when you put on a/c you could hear the fan in front kick in.
 

·
Registered
Joined
·
816 Posts
No cool air?....At nearly 4 year old, likely the refrig gas has gone, and need recharged. it can escape at the seals over time.

I used ATS Euromaster to check gas was too low, and re-charged mine at a good price (£58), cheaper than the dealer if outside of warranty.

I have base model 2016, so not climate control, just on/off A/C.
 

·
Registered
Joined
·
55 Posts
My air con button, is in the center of the round switch that you use to turn heating on, ie low to high for heater. When pressed shouldn't you hear the engine change or fan come on?
 
1 - 5 of 5 Posts
Top