Ford Ecosport Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi all

I have had my new ST line in red n black since early April, I had an 14 plate titanium + the new one is worlds apart, issues to date are
map reading lamps not working - i removed fitting and connected plug correctly
leaking widow - near side rear - went back to fords Allen's to be removed and re stuck !
Wife has named it Henry after the red / black hoover !!
I went for the moon roof, heated seats n wheel, B&O stereo front sensors and 140 bhp pack next Ebay for space saver wheel as I don't trust the tin of sealer !
Regards
 

·
Registered
Joined
·
14 Posts
Hi Three

I have the 125 ST line having previously owned a 2015 1.5 zetec i agree theres much improvement. Ive had mine 3 weeks now and ive noticed the following issues

I have a really annoying brake squeel coming from the rear everytime a gently break. If i break hard the squeel stops.

I also have an even more irritating squeak coming from somewhere in tbe back it happens if i go over uneven roads rather than bumps. Uts really high pitched and can hear it even with the radio on.

Finally sometimes not always when i go to start the car i get a low fuel warning and the fuel light comes on even when theres plenty of fuel in the car.

Anyone else had these or other issues they want to share?
 

·
Registered
Joined
·
1 Posts
Hi did you happen to find out what the squeak was?? I’ve just brought an 2018 in blue/black and the squeak is really starting to get on my nerves.
 

·
Registered
Joined
·
32 Posts
Hi,

I have the ST Line 125 also in Red/Black...BLIS, B&O & 18" Alloys....all is pretty good except for the alarm which for reasons best known sets itself off. Resetting is painful at best. Problem seems to be sorted by a hefty shove on the tailgate.....I just don't trust that back door...Have resorted to switching alarm to "Reduced Guard" in hope it's an interior sensor fault...so far so good.
Other than that all is good...Door cards are a bit flimsy and rear bench has a wee rattle....but i'm happy with the car.

Plus...had a towbar fitted today. Ford Approved electrics and detachable bar. Looks great.


Regards,

B
 

·
Registered
Joined
·
14 Posts
Hi Dan,

Sorry for the delayed response. Yes I solved the squeek. It was the uprights of the rear seats rubbing on the metal clips that hold it up when they are not folded forward. I applied Vaseline to the metal hooks and the squeaking stopped.

Hope this helps

Gav
 

·
Registered
Joined
·
1 Posts
Hello Dan, I have just joined the club in response to a general enquiry about a squeak in the rear of my 140 st line which I have put up with from new two months ago. I was debating with myself to go to the dealer and have the vehicle checked underneath. Seemed like a trivial matter but having read your account I will first see if we have similar squeaks and if so will try your remedy before going to the dealer.
 
1 - 7 of 7 Posts
Top