Ford Ecosport Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
Me again.

Ecosport wouldn't start today, first of all, opened the boot and the radio turned on. Then sat in driver's seat, pressed start butting and dash went ballistic, lots of screens flashing, finally saying I had a brake fault. Just won't start. Impressive for 550 miles and 4 weeks since delivery.

Any thoughts?
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #5 ·
Yep, really does look like the battery is the problem, will jump start it tomorrow. Although lights weren't switched on, I'm curious what drained it. Daughter fell asleep in the car and left her for not that long, with the car unlocked. Really not sure what is such a drain on the battery.
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #6 ·
Yep, battery. No lights left on so not sure what drained it. Think I'll have it checked to make sure battery is charging.
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #7 ·
What a mission!

Took to local dealer, fully booked till Wednesday next week! Ended up calling Ford Assist, AA came and diagnosed a faulty battery, so car back at Ford to be fixed within 48 hours.
 

·
Registered
Joined
·
36 Posts
took mine to fords and they didn't want to know ,said it was down to small trips and the battery not being able to recharge! i bought a new Duracell battery and all is well now , personally i just think the battery was a dud ! ..... it was less than a year old and had a [dead cell] wtf.
glad your sorted as it can be a bit daunting when all the messages about abs and such come up with the lights flashing. atvb
 
1 - 8 of 8 Posts
Top